Alt 23.02.2007, 10:11:40   #1 (permalink)
M3Y3R
Erfahrener Benutzer
Benutzerbild von M3Y3R

ID: 336361
Lose senden

Reg: 08.05.2006
Beiträge: 1.613
Standard SummeWenn()-Formel in Excel

Folgendes Problem bereitet mir schon seit einer Woche Kopfschmerzen:

Ich habe eine Formel:
=SUMMEWENN(Tabelle1!$E$4:$E$185;"<30.06.2003";Tabelle1!$D$4:$D$185)

Nun steht in Anführungszeichen das Datum. Da diese Tabelle immer größer wird, und ich bei einer evtl. änderung nicht alle Zeilen bearbeiten möchte bietet es sich ja an, dort ein Feld-Namen einzutragen.

Folgende Formel habe ich dann:
=SUMMEWENN(Tabelle1!$E$4:$E$185;"<B24";Tabelle1!$D$4:$D$185)

Ergebnis: Wenn ich dies aber mache, gibt Excel mir eine 0 aus.


Nehme ich nun die Anführungszeichen weg, dann erscheint folgende Fehlermeldung:
Die Eingegebene Formel enthält einen Fehler.
- Klicken Sie auf Hilfe...
- Klicken Sie auf OK...
- Wenn Sie versuchen eine Formel einzugeben...

Wie kann ich mein Problem lösen?
Wer kann mir weiter helfen?

Danke schon mal im Voraus!


LG Papenburger
 
M3Y3R ist offline   Mit Zitat antworten
Alt 23.02.2007, 10:24:47   #2 (permalink)
QuArK007
an Board...
Benutzerbild von QuArK007

ID: 217116
Lose senden

QuArK007 eine Nachricht über ICQ schicken
Reg: 24.04.2006
Beiträge: 1.485
Standard

Vielleicht hilft dir das hier weiter!
http://www.pcwelt.de/know-how/tipps_...241/index.html
Also damit habe ich das zumindest verstanden! Aber nicht ausprobiert!

Gruß QuArK007

Edit: ganz unten auf der Seite! Deine Formel müsste also lauten:
=SUMMEWENN(Tabelle1!$E$4:$E$185;"<"&B24;Tabelle1!$D$4:$D$185)
Dear XKeyscore, things I Like:

Linux, IRC, TrueCrypt, Tor, PGP, enigmail, Threema, TextSecure, SilentCircle, ProtonMail, startpage.com
QuArK007 ist offline   Mit Zitat antworten
Alt 23.02.2007, 10:28:54   #3 (permalink)
jperl
Erfahrener Benutzer

Reg: 21.04.2006
Beiträge: 172
Standard

soweit ich weiß musst du da das kleiner zeichen in klammer setzen und dann vor die zelle ein & hinsetzen.

also zB. SUMMEWENN(*,"<"&B24,*);

jperl

edit:
da war wohl jemand schneller.
suche immer fleißig mailerpunkte von
moneyletters (1:190)
spirit cash (1:290) e-mails4you (1:390)
jperl ist offline   Mit Zitat antworten
Alt 23.02.2007, 10:41:18   #4 (permalink)
M3Y3R
Erfahrener Benutzer
Benutzerbild von M3Y3R

ID: 336361
Lose senden

Reg: 08.05.2006
Beiträge: 1.613
Standard

Es Funktioniert.
Wieso komm ich eigentlich nicht auf die einfachste lösung mit dem UND-Zeichen.
Ich hab mir sowas shcon gedacht nur hab ich das falsch geschrieben...
hatte: <&B24
also das < nicht in "" gesetzt.

Danke euch beiden für die Hilfe...
 
M3Y3R ist offline Threadstarter   Mit Zitat antworten
Antwort

Anzeige


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[Excel] summewenn() bei nicht aneinander hängenden Bereichen joschilein Programmierung 0 10.06.2008 23:35:45
[Excel] SUMMEWENN [erledigt] Tam Programmierung 2 13.06.2007 20:22:26
Excel-Formel gesucht *erledigt* fossiebaer Software/Windows 2 28.02.2007 00:13:59
Excel Formel gesucht Champ2000 Software/Windows 2 24.02.2007 03:56:38
Excel Formel 1 mio schlopy Lose4Action 5 26.09.2006 02:35:10


Alle Zeitangaben in WEZ +1. Es ist jetzt 01:27:14 Uhr.