Alt 19.10.2007, 04:35:46   #1 (permalink)
Champ2000
Erfahrener Benutzer

ID: 79818
Lose senden

Reg: 20.04.2006
Beiträge: 4.455
Standard Microsoft Excel "SUMMEWENN" und ganz großes Problem

Hallo,
ich habe hier folgende Tabelle:


Hier brauche ich Spalte C addiert, wenn Spalte A "17.10.2007" und Spalte B "Auto". Also als korrektes Ergebnis die Zahl 58. Wie lautet hierfür die Formel?

Nach langem Nachdenken und Ausprobieren bin ich zu folgenden Formeln gekommen, nur die sind auch falsch und ich verstehe einfach nicht warum:
  • =SUMME(WENN((A34:A39="17.10.2007");WENN(B34:B39="Auto";C34:C39)))
  • =SUMME(WENN((A34:A39="17.10.2007")*(B34:B39="Auto");C34:C39))
Hat jemand eine Lösung für mich?

Gruß,
Champ

Champ2000 ist offline   Mit Zitat antworten
Alt 19.10.2007, 06:36:40   #2 (permalink)
Dragon_freak_21
Erfahrener Benutzer

ID: 261077
Lose senden

Dragon_freak_21 eine Nachricht über ICQ schicken
Reg: 22.10.2006
Beiträge: 186
Standard

probiers mal mit

=SUMMEWENNS(C34:C39;A34:A39;"17.10.2007";B34:B39;"Auto")

=summewenns(summen-bereich:kriteriumsbereich1;kriterium1;kriteriumsbereich2;kriterium2)

können auch noch mehr kriterien eingebaut werden
 
Dragon_freak_21 ist offline   Mit Zitat antworten
Alt 19.10.2007, 13:00:49   #3 (permalink)
Champ2000
Erfahrener Benutzer

ID: 79818
Lose senden

Reg: 20.04.2006
Beiträge: 4.455
Standard

Zitat:
Zitat von Dragon_freak_21 Beitrag anzeigen
probiers mal mit

=SUMMEWENNS(C34:C39;A34:A39;"17.10.2007";B34:B39;"Auto")

=summewenns(summen-bereich:kriteriumsbereich1;kriterium1;kriteriumsbereich2;kriterium2)

können auch noch mehr kriterien eingebaut werden
Ich bekomme die Fehlermeldung "ungültiger Name". Im Ausgabefel steht "#NAME?".



Champ


Geändert von Champ2000 (19.10.2007 um 13:06:34 Uhr)
Champ2000 ist offline Threadstarter   Mit Zitat antworten
Alt 19.10.2007, 13:17:26   #4 (permalink)
StefanZ
Erfahrener Benutzer

ID: 48539
Lose senden

StefanZ eine Nachricht über ICQ schicken
Reg: 20.04.2006
Beiträge: 540
Standard

Zitat:
Zitat von Champ2000 Beitrag anzeigen
nur die sind auch falsch und ich verstehe einfach nicht warum:
  • =SUMME(WENN((A34:A39="17.10.2007");WENN(B34:B39="Auto";C34:C39)))
Wie soll man denn eine Matrix (A34 bis A39) mit nur einem Wert abfragen?

Mach es mir einer verschachtelten WENN-Formel mit den beiden Bedingungen, ist wesentlich einfacher. (WENN A34="17.10.2007" und WENN B34="Auto" Dann übernimmst du den Wert von C34 z.B. in D34. Unten machst du dann einfach ne Summe aus D : D (ganze Spalte)
 
StefanZ ist offline   Mit Zitat antworten
Alt 19.10.2007, 13:55:35   #5 (permalink)
spider2123
Erfahrener Benutzer

ID: 125417
Lose senden

Reg: 16.10.2007
Beiträge: 107
Standard

arbeite mit nem hidden zwischenfeld

kolonne D versteckst du später, oder machst dei Schrift weiss, den rest siehste ja aufm bild
 
spider2123 ist offline   Mit Zitat antworten
Alt 19.10.2007, 14:07:59   #6 (permalink)
StefanZ
Erfahrener Benutzer

ID: 48539
Lose senden

StefanZ eine Nachricht über ICQ schicken
Reg: 20.04.2006
Beiträge: 540
Standard

Zitat:
Zitat von spider2123 Beitrag anzeigen
arbeite mit nem hidden zwischenfeld

kolonne D versteckst du später, oder machst dei Schrift weiss, den rest siehste ja aufm bild
Öhm ja.. genau das habe ich auch geschrieben.
 
StefanZ ist offline   Mit Zitat antworten
Alt 19.10.2007, 14:12:13   #7 (permalink)
spider2123
Erfahrener Benutzer

ID: 125417
Lose senden

Reg: 16.10.2007
Beiträge: 107
Standard

Zitat:
Zitat von StefanZ Beitrag anzeigen
Öhm ja.. genau das habe ich auch geschrieben.
öhm, achso, das stand also da...
bin ich mal gespannt welchen post die leute besser verstehen XD
 
spider2123 ist offline   Mit Zitat antworten
Alt 19.10.2007, 14:38:51   #8 (permalink)
Champ2000
Erfahrener Benutzer

ID: 79818
Lose senden

Reg: 20.04.2006
Beiträge: 4.455
Standard

Beide Beiträge sind klasse. Habe es jetzt auch so gelöst und es funktioniert super.

Champ2000 ist offline Threadstarter   Mit Zitat antworten
Alt 19.10.2007, 14:46:53   #9 (permalink)
Secret
Your little Secret
Benutzerbild von Secret

ID: 127381
Lose senden

Secret eine Nachricht über ICQ schicken
Reg: 20.04.2006
Beiträge: 1.866
Standard

Kannst auch hinter die Zahlen in ein freies Feld das einfügen:

=WENN(UND(A38=DATUM(7;10;17);B38="Auto");C38+D37;D37)

Und dann einfach nur runterziehen.


Edit: naja .. zu spät *g*
Secrets erweiterte Sig (14.11.)

In Gedenken an Maja und Jack. Wir werden euch nie vergessen.
Secret ist offline   Mit Zitat antworten
Alt 19.10.2007, 15:51:03   #10 (permalink)
Dragon_freak_21
Erfahrener Benutzer

ID: 261077
Lose senden

Dragon_freak_21 eine Nachricht über ICQ schicken
Reg: 22.10.2006
Beiträge: 186
Standard

Zitat:
Zitat von Champ2000 Beitrag anzeigen
Ich bekomme die Fehlermeldung "ungültiger Name". Im Ausgabefel steht "#NAME?".



Champ
der fehler ist einfach das du das Auto in gänsefüsschen gesetz hast... ohne sollte es gehn

hab es bei mir ja getestet und so rauskopiert wie die formel im feld stand
kopier einfach die formel rein und änder die felder so wie du se brauchst
 
Dragon_freak_21 ist offline   Mit Zitat antworten
Antwort

Anzeige


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[Debian] iptables/squid - "redirect"+"transparenter proxy" Problem [gelöst] Geini Linux & Co 3 18.08.2008 19:21:18
Großes Problem mit Microsoft Visio 2007! NWsimon1702 Software/Windows 0 13.03.2008 18:49:02
Game Boy spiele "DuckTalers 2", "Super Mario Land", "Goal!" Bani Lose4Misc (erledigt) 1 13.03.2007 11:34:57
GAnz großes ICQ problem cojac Spyware & Virenprobleme 27 02.08.2006 00:17:28
ganz ganz simpel *schäm* objekte "festtackern" bandit2k1 Programmierung 3 14.06.2006 17:38:50


Alle Zeitangaben in WEZ +1. Es ist jetzt 23:24:40 Uhr.