Alt 20.04.2011, 11:14:44   #1 (permalink)
grunge_e_nut
Neuer Benutzer

Reg: 20.04.2011
Beiträge: 3
Standard Exceltabelle auswerten. Makros? Filter?

Hallo zusammen
ich habe hier aus einer Umfrage ein sehr große Datenbank. Es haben fast 300 Leute auf insgesamt ca. 100 Fragen geantwortet. Die Antworten sind mit 1,2,3,0 und 99 codiert.

Bisher mache ich es so: ich setze in der entsprechenden Spalte (zB Frage M1) einen Filter auf z.B. 3 und lasse mir dann mit =ANZAHL(...) die Anzahl anzeigen und entsprechend den Anteil in % berechnen.

Jetzt muss ich aber bei jeder Frage den Filter für Antwort 3, dann für 2, dann für 1 usw. neu setzen. Hier wäre meine Frage: Kann ich die Ergebnisse für alle Filtervorgänge im Gesamten anzeigen lassen oder mir vielleicht mit einem Makro helfen? Damit habe ich allerdings noch gar keine Erfahrung - kenne daher die Möglichkeiten nicht so gut.

Wäre toll, wenn ihr mir da helfen würdet - die Arbeit artet hier sonst extremst in Klein-Klein aus. Sysiphus lässt grüßen
 
grunge_e_nut ist offline   Mit Zitat antworten
Alt 20.04.2011, 11:32:33   #2 (permalink)
Wasweissdennich
Hakuna Matata
Benutzerbild von Wasweissdennich

ID: 96572
Lose senden

Reg: 21.04.2006
Beiträge: 11.039
Standard

Befrage mal Google nach "Pivottabelle in Excel" die faßt Dir sowas sinnvoll zusammen und kann man für Vieles brauchen.
 
Wasweissdennich ist gerade online   Mit Zitat antworten
Alt 20.04.2011, 12:54:36   #3 (permalink)
grunge_e_nut
Neuer Benutzer

Reg: 20.04.2011
Beiträge: 3
Standard

Danke für den Tipp aber die Tabelle ist fix. Die wurde von der Datenbank als csv ausgeworfen und ähnelt im Grund auch dem was ich über Pivot gelesen hab. Aber ich muss ja trotzdem da geschickt die Daten rausziehen und da liegt bei mir der Hase im Pfeffer.

Ich hab inzwischen rausgefunden, dass das mit der WENNZÄHLEN-Funktion gut klappt. Jedoch anscheindend nur bei Zahlenwerten - bei Buchstaben kommt die "0"

Jetzt habe ich eine Tabelle unter meiner Tabelle angelegt in der immer abwechselnd untereinander die Anzahl derer die zB. Antwort 3 gewählt haben und der entsprechende Anteil stehen. Also So:

123
52,73%

52
14,63%

203
73.82%

Gibts da ne Möglichkeit das für die vielen verschiedenen Items in eine Tabelle in Word einzufügen? Pro Zelle soll dann in Klammern die Anzahl und drüber die Anteile stehen.

so:

64,29 %
(63)

Vielleicht per Makro? Geht das Programmübergreifen bei Office?

Und noch eine zweite Frage: Ich will die Tabelle später noch nach dem Alter auswählen. Dazu würde ich dann ja noch eine zweite Variable hinzuziehen. Also zum Beispiel wer im Alter von 16 hat Antwort 3 gewählt. Dann brauche ich die Spalte "Alter" und die Spalter der Frage, z.B. "L3" - kann das die Wennzählen Funktion auch?

Vielleicht kennst du auch noch eine elegantere Variante?
 
grunge_e_nut ist offline Threadstarter   Mit Zitat antworten
Alt 26.04.2011, 20:14:33   #4 (permalink)
grunge_e_nut
Neuer Benutzer

Reg: 20.04.2011
Beiträge: 3
Standard

Hi,
ich nochmal.

Also die Tabelle steht jetzt so weit. Jetzt habe ich noch eine Frage:

Ich habe jetzt eine Reihe Tabellen die sich auf eine Frage mit bestimmter Zeile beziehen:

So ist beispielsweise in der Zelle Männlich mit Antwort "oft" folgende Formel:
=ZÄHLENWENNS(AW2:AW289;3;C2:C289;2)

Das geht dann weiter bis zu Alter 18-21 Jahre mit der Antwort "weiß nicht"
=ZÄHLENWENNS(AW2:AW289;99;B2:B289;1+ZÄHLENWENNS(AW2:AW289;99;B2:B289; 19)+ZÄHLENWENNS(AW2:AW289;99;B2:B289;20)+ZÄHLENWENNS(AW2:AW289;99;B2:B2 89;21)

Insgesamt ein ganzer Haufen Zellen und alle mit dem Bezug zur Spalte AW2 bis AW 289

Jetzt käme im Anschluss die nächste relevante Spalte - das ist BC2 bis BC289 - Auf Grund der Breite der Tabelle kann ich aber nicht einfach kopieren und Excel die Bezüge automatisch ändern lassen - da käme dann der Bezug automatisch zur Spalte BE und die brauche ich ja nicht. Gibt es eine Möglichkeit das einfach zu ändern, ohne dass man jede einzelne Formel ändern muss? Ich habe es schonmal mit "alle ersetzen" versucht aber das geht nicht - jetzt hab ich keine Idee mehr dazu.

Genau das Selbe ist bei der Umrechnung in Prozente. Da ist es dann die Anzahl durch ein ganz bestimmtes Feld - auch hier müsste nur der Bezug geändert werden, nicht die ganze Formel.

gibts da irgendwas schnelles/praktisches/einfaches/tolles?

danke schonmal!
 
grunge_e_nut ist offline Threadstarter   Mit Zitat antworten
Alt 29.04.2011, 09:37:32   #5 (permalink)
papslf58
Erfahrener Benutzer

ID: 299957
Lose senden

Reg: 14.10.2007
Beiträge: 883
Standard Statistik

Hallo

Und warum macjht man siowas ncith mit einem echten Statistikprogramm ?
Kostenlos gibts sowas auch, z.B. R-Cran, incl. schöner Auswertung per Grafik.
 
papslf58 ist offline   Mit Zitat antworten
Antwort

Anzeige


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Frageboegen auswerten Tab Software/Windows 4 28.10.2009 07:47:41
[s] Progger für Exceltabelle Buster99 Lose4Scripts (erledigt) 3 14.10.2008 17:36:09
Frage Suche FTP-Programm, welches Programmabläufe / Art Makros erlaubt php Software/Windows 0 14.06.2008 14:34:07
[PHP] csv Auswerten 27o8 Programmierung 2 07.12.2007 23:47:44
PHP Formular auswerten Matthias Programmierung 4 26.09.2007 22:28:01


Alle Zeitangaben in WEZ +1. Es ist jetzt 23:31:59 Uhr.